Error 0x287F

Support forum for the Lambda Shield designed to connect Bosch LSU 4.9 wideband oxygen sensors to Arduino projects.
Post Reply
Paul
Posts: 3
Joined: 02 Feb 2023 19:46

Error 0x287F

Post by Paul » 02 Feb 2023 19:57

Hi I have a problem with lambda shield 2 with original Bosch sensor.
The system was working fine but suddenly stops reporting.
When I check the serial monitor I receive error code 0x287F (no sensor connected) is there any way to troubleshoot it or is it possible that the sensor is dead?

User avatar
Christian_Bylund
Posts: 261
Joined: 07 Mar 2015 18:09

Re: Error 0x287F

Post by Christian_Bylund » 06 Feb 2023 05:33

Paul wrote:
02 Feb 2023 19:57
Hi I have a problem with lambda shield 2 with original Bosch sensor.
The system was working fine but suddenly stops reporting.
When I check the serial monitor I receive error code 0x287F (no sensor connected) is there any way to troubleshoot it or is it possible that the sensor is dead?
Hi Paul,

Based on the error code it seems that the heater wire in the sensor is broken. Please also check that there is no problem with the wires or the supply voltage. What supply voltage are you using?

Thank you.
Best Regards,
Christian Bylund
Bylund Automotive AB

Paul
Posts: 3
Joined: 02 Feb 2023 19:46

Re: Error 0x287F

Post by Paul » 07 Feb 2023 14:27

I use a laptop power supply with about 19V connected to the shield.
The wires looks good, I also measured the voltage and it was about 19V.

User avatar
Christian_Bylund
Posts: 261
Joined: 07 Mar 2015 18:09

Re: Error 0x287F

Post by Christian_Bylund » 08 Feb 2023 07:09

Paul wrote:
07 Feb 2023 14:27
I use a laptop power supply with about 19V connected to the shield.
Hi Paul, using a voltage higher than 16.5V may reduce the lifetime of the Bosch LSU 4.9 sensor.
Best Regards,
Christian Bylund
Bylund Automotive AB

Paul
Posts: 3
Joined: 02 Feb 2023 19:46

Re: Error 0x287F

Post by Paul » 14 Mar 2023 20:16

Ok but in the manual it says 15-20V and not mentioning about that it would be to high for the sensor. The kit is about one year old and sad to need a new sensor that soon.

Post Reply