CJ125 error with SD-card

Support forum for the Lambda Shield designed to connect Bosch LSU 4.9 wideband oxygen sensors to Arduino projects.
Post Reply
EBSolution
Posts: 3
Joined: 26 Jul 2021 22:24

CJ125 error with SD-card

Post by EBSolution » 26 Jul 2021 22:36

Good evening,
I use the lambda Shield with an official Arduino Mega.
I use 12V 2A on the arduino DC input and connect lambda Shield using X7 connector.

When i start the sample code I have only CJ125 Error 0xFFFFFF.

Any Idea what's happening?
Thanks for your help.

User avatar
Christian_Bylund
Posts: 205
Joined: 07 Mar 2015 18:09

Re: CJ125 Error 0xFFFFFF

Post by Christian_Bylund » 26 Jul 2021 22:44

EBSolution wrote:
26 Jul 2021 22:36
Good evening,
I use the lambda Shield with an official Arduino Mega.
I use 12V 2A on the arduino DC input and connect lambda Shield using X7 connector.

When i start the sample code I have only CJ125 Error 0xFFFFFF.

Any Idea what's happening?
Thanks for your help.
Hi EBSolution, are you using the original Lambda Shield or the Lambda Shield 2?

Thank you.
Best Regards,
Christian Bylund
Bylund Automotive AB

EBSolution
Posts: 3
Joined: 26 Jul 2021 22:24

Re: CJ125 Error 0xFFFFFF

Post by EBSolution » 26 Jul 2021 23:11

It is the lambda Shield 2

User avatar
Christian_Bylund
Posts: 205
Joined: 07 Mar 2015 18:09

Re: CJ125 Error 0xFFFFFF

Post by Christian_Bylund » 26 Jul 2021 23:22

EBSolution wrote:
26 Jul 2021 23:11
It is the lambda Shield 2
This indicates that there is a problem with SPI communication.

1. Can you please share a picture of your set up?
2. Are you using the example code without modifications?

Thank you.
Best Regards,
Christian Bylund
Bylund Automotive AB

EBSolution
Posts: 3
Joined: 26 Jul 2021 22:24

Re: CJ125 Error 0xFFFFFF

Post by EBSolution » 27 Jul 2021 12:52

Hi,

I've found the reason: i have an sd Card reader connected to the SPI BUS using pins 50 to 52 and Chip Select pin 53.
If I disconnect this SD card Reader, everything works fine.

I see that CJ125 SPI communication uses pin 10.

The SD SPI communication don't specify any chip select so it should be pin 53 for arduino Mega.
How can I use both Lambda shield2 and sd card reader on a Mega board?

Thanks for your quick replies and have a good day.

EBS

User avatar
Christian_Bylund
Posts: 205
Joined: 07 Mar 2015 18:09

Re: CJ125 Error 0xFFFFFF

Post by Christian_Bylund » 27 Jul 2021 15:31

Excellent, then I can tell you that you may also have a problem with the SD-card adapter.

Have a look at this video for more information on how to use a SD-card sharing the SPI bus with the CJ125.

Thank you.
Best Regards,
Christian Bylund
Bylund Automotive AB

Post Reply