Lambda Shield not working!!!

Support forum for the Lambda Shield designed to connect Bosch LSU 4.9 wideband oxygen sensors to Arduino projects.
Terrigeno
Posts: 1
Joined: 11 Jul 2018 20:22

Lambda Shield not working!!!

Postby Terrigeno » 11 Jul 2018 20:47

Hello,

we had a problem with our lamba shield and the capacitor (C5) broke / snapped from the board during instalation.
We tried soldering it again and we made a test. The shield turns on but the heating led starts blinking and doesn't stop.
I tried opening the software but it just keeps "heating" but is doesn't ever heat.

Any ideas what may be causing this problem? What can we do?

thanks in advance,

Terrigeno Team

User avatar
Christian_Bylund
Posts: 24
Joined: 07 Mar 2015 18:09

Re: Lambda Shield not working!!!

Postby Christian_Bylund » 12 Jul 2018 10:40

Hi!

Unfortunate with the C5 capacitor. Assuming that you have soldered it in place and it is working. It sounds like you are using a non original sensor. Please confirm you are using an original Bosch LSU 4.9 wideband sensor? If it is an original Bosch sensor, please let me know the pnc of it.

Thank you.
Best Regards,
Christian Bylund
Bylund Automotive AB